Firefox Extensions and Themes - Add features and alter interface of best browser on the Net
Mozilla Firefox makes browsing faster and more secure.
Start searching!  



US Department of Homeland Insecurity Idiocy Level


Displays the current Idiocy Level in the status bar.





Supported Firefox versions: Firefox 1.0 - 2.0.0.* ALL

Notes / Comments: That's an interesting one. Are you sure that it only happens when you have a java-based game running in the browser? I'll look into it.Also, the 2.0.*-ready version is uploaded and pending approval, so all you bleeding-edgers can have a go at it!

Category Categories: Blogging, Humor, Miscellaneous, Privacy and Security, Website Integration








Download US Department of Homeland Insecurity Idiocy Level [Firefox plugin] Install: US Department of Homeland Insecurity Idiocy Level




 




Friend's:

Get a Freelance Job - Outsource Web Design & Programming | Dictionary - Define Words | Wordpress blog for FREE | Coupons: Threadless



Powered by FF Extensions
Plug-in CategoriesPrivacy Policy
All rights reserved.